Service Disruption Alert
Incident Report for InboxAware
Resolved
This incident has been resolved. All current inbox placement metrics are visible within InboxAware. A separate task is in progress to restore data from Feb 7 to Feb 14 for historical purposes.
Posted Feb 16, 2022 - 00:29 EST
Monitoring
We have identified the root cause of inbox placement data missing from late Feb 7 to early Feb 14. All data is still present within the system. We are currently working to restore the data so that it is visible within the application.
Posted Feb 15, 2022 - 12:23 EST
Investigating
InboxAware is experiencing difficulty with its data storage. Data for Inbox Placement reports for the past 7 days is not currently available.

We are working to identify the issue and rectify it as soon as possible.
Posted Feb 14, 2022 - 19:10 EST
This incident affected: Web Application.